-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathCheckArrayRotation.cpp
61 lines (50 loc) · 1.03 KB
/
CheckArrayRotation.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
You have been given an integer array/list(ARR) of size N. It has been sorted(in increasing order) and then rotated by some number 'K' (K is greater than 0) in the right hand direction.
Your task is to write a function that returns the value of 'K', that means, the index from which the array/list has been rotated.
Sample Input 1:
1
6
5 6 1 2 3 4
Sample Output 1:
2
// My Code:
int arrayRotateCheck(int arr[], int n) {
int count=1;
bool check = false;
for(int i = 0; i < n-1; i++){
if(arr[i] <= arr[i+1]){
count++;
}
else{
check = true;
break;
}
}
if(check == false){
return 0;
}
else{
return count;
}
}
// Main Code:
#include <iostream>
using namespace std;
#include "solution.h"
int main()
{
int t;
cin >> t;
while (t--)
{
int size;
cin >> size;
int *input = new int[size];
for (int i = 0; i < size; i++)
{
cin >> input[i];
}
cout << arrayRotateCheck(input, size) << endl;
delete[] input;
}
return 0;
}